Un petit problème avec XML

Random questions or observations about and around computers
Post Reply
User avatar
Mehdi H. IRAQI
Membre projet CRT
Posts: 13
Joined: Wed Sep 30, 2009 3:52 pm

Un petit problème avec XML

Post by Mehdi H. IRAQI » Sat Jul 03, 2010 11:30 am

Bonjour,

j'ai un problème avec XML c'est que quand j'écris dans mon code source par exemple :

...
<imp contrainte=" x <= n "/>
...

ça crée un problème, et le fichier ne veut plus être lu par mon parseur.

donc j'ai cherché et j'ai trouvé que c'est le inférieur " < " qui crée problème parce que il suffit d'enlever le " < " pour que tout marche correctement.
y'a t'il moyen pour écrire" < " sans que ça plante ???

Merci.

User avatar
Vincent
Posts: 3077
Joined: Fri Apr 07, 2006 12:10 pm
Location: Schtroumpf
Contact:

Re: Un petit problème avec XML

Post by Vincent » Sat Jul 03, 2010 12:16 pm

Grâce à ma super expertise (sisi) en XML, j'ai réussi (mais c'était dur, hein, ça a pris au moins 15 longues secondes) à googler sur les mots-clef "XML character codes" et miracle, je suis tombé là-dessus, ce qui je crois répond à ta question:

http://en.wikipedia.org/wiki/List_of_XM ... references

Donc < = <


incroyable hein ? (*insérer ici in smiley "google")
{ Vincent Hugot }

User avatar
Mehdi H. IRAQI
Membre projet CRT
Posts: 13
Joined: Wed Sep 30, 2009 3:52 pm

Re: Un petit problème avec XML

Post by Mehdi H. IRAQI » Sat Jul 03, 2010 1:04 pm

Bon moi je connaissais la réponse c'est juste pour tester tes connaissances :D

Merci pour tes 15s c'est tout bon !

Post Reply

Who is online

Users browsing this forum: No registered users and 213 guests